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1 Introduction 

1.1 About this Exercise Book 
This is the exercise book for Site Recorder 4, the digital information management system for 
maritime and intertidal archaeology.   
 
The book contains a series of exercises that allow you to get familiar with all the features in the 
program.  The exercises should be completed in the order given as later exercises use 
knowledge gained in previous work or use Site files created in earlier exercises.  Earlier 
chapters cover features that are most commonly used leaving the later chapters to cover more 
advanced features.  
 
The book is provided in electronic form as a PDF document as this allows easy navigation 
between topics as well as the use of a powerful search capability.  The manual can be printed 
by going to the print option in the File menu.   
 

 
 
Names of kinds of objects that can be added to Site Recorder or their properties are shown 
starting with a capital letter, such as ‘Survey Point’ and ‘Artefact’.  The names of the objects 
themselves are shown in italics.  Technical and Site program specific words are described in the 
separate Glossary document. 
 
In the text some actions are summarised in a shorthand form as hints, for example (File | Save 
Site) means select the Save Site option in the File menu. 
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1.2 About Site Recorder 4 
Site Recorder 4 is a fully-featured and versatile Geographic Information System (GIS) and data 
management system specifically designed for use in maritime and intertidal archaeology.  Site 
Recorder is powerful yet easy to learn and has been designed by archaeologists for 
archaeologists. 
 
With Site Recorder you can collect together all of the information about an underwater or inter-
tidal site in one place.  Separate pieces of information can then be associated with one another 
allowing easy location, analysis and interpretation of the information.  Unlike most other GIS 
programs, Site Recorder is designed for collecting information not just displaying it. Site 
Recorder has been designed to replace the separate surveying, drawing, finds handing and 
reporting programs usually used on site with one single program.  All data can be geo-
referenced and time-stamped allowing true 4 dimensional analysis. 
 
Typical applications for Site Recorder 4 include: 
 

• Excavation planning and recording 

• Site survey planning and recording 

• Geophysical survey post-processing 

• Resource evaluation and management 

• Site publication and reporting 

• Archiving site data 

With all of the information about a site captured in a Site file it can be used as a basis for 
creating reports or exported for further processing in other programs.  Complete sites and 
associated image and source files can be published on CD or DVD along with a free reader 
program called Site Reader.  With the entire Site information in one place and linked together 
this also forms an ideal method for archiving site data. 
 
Site Recorder 4 is protected with a software key or ‘dongle’, however the program can be used 
without a software key in a demonstration (Demo) mode which has limited capability.  This 
feature has been added so the program can easily be used for training and evaluation without 
the need for a software key to be provided.  In Demo mode the number of some objects that can 
be added is restricted, the program only loads and saves special Site Recorder Demo (.rdd) 
files and a few tools locked and cannot be used. 
 
If the program is started without a dongle being attached to the computer then it will revert to 
Demo mode.  To switch to full operating capability the program must be stopped, the software 
key connected to the computer and the program restarted. 
 
Site Recorder SE (Student Edition) is a free survey processing and mapping program 
compatible with Site Recorder. 
 

The Software Key 

Site Recorder 4 is protected by a software key or dongle that plugs in to a USB port on your PC 
and it is this that allows the program to be used.  If the program is started without the key being 
plugged in to the computer then the program will start up in Demonstration (Demo) mode which 
has limited capability (see below).  The dongle contains the license for the program so must be 
kept secure and you are responsible for its safety.  If the software key is lost then a new license 
for the program has to be purchased.  If the dongle is damaged then a replacement may be 
provided by 3H Consulting Ltd. at the company’s discretion. 
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1.3 Demonstration (Demo) Mode 
Site Recorder 4 is protected with a software key or ‘dongle’, however the program can be used 
without a software key in a demonstration (Demo) mode which has limited capability.  This 
feature has been added so the program can easily be used for training and evaluation without 
the need for a software key to be provided.  In Demo mode the number of some objects that can 
be added is restricted, the program only loads and saves special Site Recorder Demo (.rdd) 
files and a few tools locked and cannot be used. 
 
If the program is started without a dongle being attached to the computer then it will revert to 
Demo mode.  To switch to full operating capability the program must be stopped, the software 
key connected to the computer and the program restarted. 
 
The limitations on the number of objects that can be added in Demo mode are: 
 
Object Number 
Projects 3 
Layers 6 
Points 10 
Polylines 10 
Circles 10 
Text 10 
Artefacts 10 
Features 10 
Sectors 10 
Samples 10 
Wrecks 10 
Targets 10 
Images 10 
Drawing Frames 1 
Image Basemaps 1 
Search Areas 1 
Survey Points Unlimited 
Measurements Unlimited 
Contacts  Unlimited 
Sources  Unlimited 
Events  Unlimited 
Dive Logs  Unlimited 
 
In Demo mode the other limitations include: 
 

• Reads and writes SR4 Demo files, reads Site Recorder SE (.rse) files and cannot read 
or write standard Site Recorder files with file name extension ‘.rcd’.  SR4 Demo files 
have the file name extension ‘.rdd’. 

• The Image Processing tool is not available 
• The Add Multiple tool is not available 
• The Add Observations tool is not available 
• Site file sharing is not available 
• Tours are not available 
• The Navigation bar is not available 
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2 Getting further assistance 

Online Help 
Any of the Help buttons in Site Recorder show the document you are currently reading.  To 
show this document, select Help Topics from the Help menu. 
 
More information and example Site files can be found on the 3H Consulting web site found at:  
 
http://www.3HConsulting.com 

Training 
It is recommended that all new users familiarise themselves with the program by completing the 
exercises set out in this Exercise Book.  Training courses can be provided for new users just 
starting with the program or experienced users wishing to develop their skills.  Please contact 
3H Consulting for more information. 

Assistance with Problems 
Problems and bugs should be reported to 3H Consulting Ltd by email, describing the nature of 
the problem and if possible the steps taken to reproduce it. 
 
In some instances it is helpful to know the configuration of the computer showing the reported 
problems.  The full configuration can be found using the System Information tool found on the 
About dialog available from the Help menu. 
 
Support can be obtained directly from 3H Consulting Ltd. by sending an email to:  
 
info@3HConsulting.com 
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3 Starting Site Recorder 

3.1 Exercise – Add an Object 
In this exercise we will create a new Site, add a single Survey Point to it then show the point in a 
List Display. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. In the New Site Wizard, use the default settings and click Close 

Set the Survey layer as the current layer: 
4. On the Layers display, click on the Layer called 2010 Control in the Project called 2010 

Season (See note below) 

5. Click the Set current button  or right click and select Set Current from the context 
menu.  Check that the 2010 Control label is now in bold font, showing that it is now the 
current Layer. 

Note: The name of the Layer and Project made by the program includes the year so if the year 
is 2011 then the name of the Layer will be 2011 Control. 

Add a Survey Point: 
 

1. Click anywhere on the chart display to select it 

2. Click the Add button  on the Main toolbar 
and select Survey Point 

3. Click a point on the chart where you want the 
Survey Point to be placed 

4. The property page for the Survey Point will now be 
shown, for now just click OK 

5. Click the Select button  on the Main Toolbar 
or press the ESC key to stop adding Survey Points 

 
The Survey Point will be shown on the chart as a small shape with the name CP01. 

Show the Survey Point in the List Display 

1. On the Main toolbar, click the Add New Display button  and select Survey 
Points 
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2. In the List Display, double click anywhere on the row for Survey Point CP01 to show its 
properties pages. 

 
 
 

3. Click on the right hand column of the Name property (where it says CP01) and type in 
the new name TEST. 

4. In the properties pages, click OK 

5. Check that the new name has been 
set in both the List Display and the 
Chart. 

6. Close the List Display by clicking the 

red cross in the top-right corner  of 
its window. 

 
 
 
 
 

Save the new Site file 
1. Select Save Site from the File menu 

2. If prompted, type in the new name for the file as Exercise and click OK 

 
 
Now go to the next exercise below in the section Working with Projects and Layers. 
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4 Working with Projects and Layers 

4.1 Exercise – Projects and Layers 
In this exercise we will modify the default Project and set up the Layers on it.  We will show how 
Layers can be shown and hidden on the chart, how the Layer can be changed for any object 
and how Layers can be locked and unlocked. 

Modify the Project: 
1. Ensure that the Site file Exercise created in the previous exercise is loaded or follow the 

instructions described above 

2. Show the Layers display by clicking the Show Layers button on the Main Toolbar  

3. Double click the Project called 2010 Season and show its property page 

4. In the Project’s properties page type in the name 2007 Season and an optional 
Description of ‘Data collected during the 2007 excavation’.  Click OK. 

Modify the Layers: 
The Project ‘2007 Season’ contains default Layers, these need to be modified. 
 

1. If not shown already, show the Layers in the new Project by clicking on the tree in the 
Layers display 

2. Select the Layer 2010 General, show its properties and change its name to 2007 
Sketch 

3. Select the Layer 2010 Control, show its properties and change its name to 2007 Control 

4. Select the Layer 2010 Detail and click the Delete button  on the Layers toolbar to 
delete it.  Click Yes at the prompt 

5. Select the Layer 2010 Artefacts, show its properties and change its name to 2007 Guns 

6. Save the Site file (File | Save Site) 

 
 
The Layers display should now look like this: 
 
 
 
 
 
 
 
 
 
 
 

Showing and Hiding Layers on the Chart 
Each layer can be shown or hidden individually. 
 

1. Click on the lightbulb icon  for the Layer called 2007 Control to hide it 

2. Check that the lightbulb icon changes and the Survey Point called TEST disappears 
from the chart 

3. Click on the same icon and check that the Survey Point now reappears 
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Setting the Layer for an Object 
The Layer that an object is on can be changed.  In this exercise we change the Layer for an 

yer to prove the Survey Point has moved from one Layer to object then show and hide that La
another. 

1. On the Layers Display, click the Add toolbar button  

2. In the Add New dialog, select Survey Layer then click OK 

me property to 2010 Control 
yers Display. 

3. The Survey Layer properties page is shown, set the Na
then click OK.  Check that the new Layer is shown in the La

4. On the Chart, double click the Survey Point called TEST added in the previous 
exercise.  The properties page for the Survey Point will be shown 

5. Click on the Layer property and a list of Survey Layers will be shown: 

 
 

6. eck that this name is now shown in the 

splay, hide the Layer called 2010 Control (using the lightbulb icon) and 
appears to show that the point is now on a 

Layers can be locked so they cannot then be modified, this can protect against accidental 
 Layers can then be unlocked if modifications are required. 

Click on the Layer called 2010 Control and ch
Layer property 

7. In the Survey Point property page click OK 

8. In the Layers di
check that the Survey Point called TEST dis
different Layer 

9. Show the Layer called 2010 Control and check that TEST reappears 

Locking Layers 

changes.  Locked
 

1. In the Layers Display, click the open padlock icon  next to the Layer called 2010 
Control to lock the Layer 

rties are disabled and cannot be changed 

ges 

2. On the chart, double click the Survey Point called TEST to show its properties 

3. Check that all of the prope

4. Check that the word ‘LOCKED’ appears in the blue title bar of the properties pa
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5. In the properties pages, click OK 

6. On the chart, check that the four squa  grips surrounding the Survey Point are now 
objec s locked. 

re
t ishown in grey, indicating that this 

7. In the Layers Display, click the closed padlock icon next to the Layer called 2010 
Control to unlock the Layer 

8. Show the properties for the Survey Point called TEST and check that they can now be 
changed 

 
 
Now go to the next exercise below in the section Setting up the Site. 
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5 Setting up the Site 

5.1 Exercise – Setting up the Site 
In this exercise we will set the properties for the Site itself. 

Modify the Site: 
1. From the Tools menu, select Site Properties to open the properties pages for the Site 

2. In the Properties page, click the Name property and set this to Mary Rose. 

3. Type in a Description, Site Code and any other properties you like 

4. Click OK to close the properties pages for the Site 
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6 The Find Tool 

6.1 Exercise – Using the Find Tool 
Where large amounts of data are stored in a 
Site file finding particular objects can be time 
consuming.  A quick way to find an object or 
to find objects with similar names is to use the 
Find Tool.  This exercise demonstrates the 
use of the Find Tool. 
  
 
 
 
 
 
 
 
 
 

To open the example Site file: 
1. From the File menu, click Open Site 

2. In the Open Site File dialog click the Open button 

3. Navigate to the folder C:\Site Files\Sample Files (see image below) 

4. Open the Site file Exercise Adjust Test.rdd 
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To use the Find Tool: 
1. Select Find Tool from the Tools Menu or click CTRL-F 

2. Type in the name of the object CP04  

3. Press the Find button on the Find Tool and the object that matches the name is shown  

4. Double click on the Artefact CP04 in the list to show its properties 

5. Click the Show on Chart button to show the chart centred around the selected object(s) 

6. Click the Show in List button to show the object in the Artefact List Display 

7. In the Find Tool, type in the name CP* and click the Find button 

8. The list now shows seven objects with names that match as * is a wildcard and can 
represent any letter or number 
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7 Adding a Preliminary Sketch 

7.1 Exercise 1 - Points 
In this exercise we will add, modify and delete a drawing Point. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. On the New Site Wizard, set the site name to Drawing Point then click Close 

Add and modify a Point: 
1. In the Layers Display, select the Layer called 2010 General and click the Set Current 

button  

2. On the Drawing Toolbar, click Add Point  

3. Click anywhere in the middle of the Chart and a new Point will be added 

4. On the Point properties page, type in a name for the point (optional) then click OK 

 
We can move the Point somewhere else: 
 

1. Select the Move tool from the Main toolbar  

2. On the Chart, click on the new Point or its blue grips and drag the Point to a new 
location 

 
We can change the Layer the Point is on: 
 

1. In the Layers display click the Add button  on the toolbar, select General Layer 
and click OK 

2. In the new Layer’s properties type in a Name of Drawing 3 and click OK 

3. Show the properties for the Point by double clicking it on the chart and set the Layer 
property to Drawing 3.  Click OK to close the property pages. 

 
We can change how the Point is drawn using the Layer: 
 

1. In the Layers display, double-click the Layer Drawing 3 to show its properties. 

2. Set the Point Style property to Square and click OK, the Point is now drawn with a 
square symbol 

 
We can finally delete the Point: 
 

1. Select the point and click the Delete button  on the Main toolbar 

2. At the prompt click Yes 
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7.2 Exercise 2 – Polyline Editing 
In this exercise we will add, move, rotate and modify a Polyline. 

Create a new Site: 
3. From the File menu select New Site 

4. If prompted, save the old Site file if required 

5. On the New Site Wizard, set the site name to Drawing Polyline then click Close 

Add and modify a Polyline: 
6. In the Layers Display, select the Layer called 2010 General and click the Set Current 

button  

7. On the Drawing Toolbar, click the Add Polyline button  

8. Left-click with the mouse on the Chart where you want to start the line, move the cursor 
and left-click to draw the next vertex 

9. Repeat the left-clicks until three or four vertices have been drawn then right-click with 
the mouse to stop drawing the Polyline 

 
We can move the Polyline somewhere else: 
 

1. Select the Move tool  from the Main toolbar 

2. Click on one of the lines or grips and drag the whole Polyline to a new location 

 
We can rotate the Polyline about its centre: 
 

1. Select the Rotate tool  from the Main toolbar 

2. Click on one of the lines or grips and drag the whole Polyline to rotate it 

 
We can move just one of the vertices: 
 

1. Select the Move Vertex tool  from the Drawing Toolbar 

2. Click on a vertex (place where two lines join) on the Polyline and drag the vertex to a 
new location 

 
We can make the Polyline a closed shape by moving the last point on top of the first: 
 

1. Ensure the Move Vertex tool is still selected on the Drawing Toolbar 

2. Click on the blue grip on either end of the Polyline and move it on top of the grip on the 
other end 

 
We can add an extra vertex on the Polyline: 
 

1. On the Drawing toolbar, click Add vertex  

2. Click anywhere on one of the Polyline’s lines to add a new vertex 

3. Try moving the new vertex using the Move Vertex tool 
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We can delete a vertex from the Polyline: 
 

1. On the Drawing toolbar, select Delete Vertex  

2. Click on the vertex to be deleted 

 
We can open our closed Polyline: 
 

1. Click on the Polyline to select it 

2. Right click anywhere on one of the Polyline’s lines and select Open/Close Polyline 

 

7.3 Exercise 3 – Polyline Style 
In this exercise we will change the colours and style for Polylines using the default values for a 
Layer and locally set properties in a Polyline. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. On the New Site Wizard, set the site name to Drawing Polyline then click Close 

Add two Polylines: 
1. In the Layers Display, select the Layer called 2010 General and click the Set Current 

button  

2. On the Drawing Toolbar, click the Add Polyline button  

3. Left-click with the mouse on the Chart where you want to start the line, move the cursor 
and left-click to draw the next vertex 

4. Repeat the left-clicks until four or five vertices have been drawn then click on the start of 
the line (the first vertex) to close the Polyline 

5. Repeat steps 2-4 above to add a second closed Polyline 
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Modify the Layer Colour and Style Properties 
We can now change the colour and style for the Polylines.  By default any object added to a 
Layer uses that Layer’s style but objects like Polylines can be set to use their own style instead. 
 

1. In the Layers Display, double click the Layer 2010 General to show its properties 

2. For the Pen Colour property, click the coloured square in the right hand column then 
click the red square in the colour table 

 

 
 

3. In a similar way, set the Fill Colour property to yellow then click OK 

4. Check that the two polylines are now shown with red outlines and yellow fill 

 
5. On the chart, double click the edge of one of the Polylines to show its properties 

6. Set the Pen Colour property to blue, the Line Style to Dash and the Fill Style to 
Diagonal and click OK 

 
7. Check that the chart now looks similar to the above 
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8 More about drawing 

8.1 Exercise 1 – Polyline Join, Copy and Scale 
A common task is to join Polylines together to make a single Polyline.  We also need to be able 
to scale a Polyline to make it larger or smaller in one axis or both axes at the same time. 
 
In this exercise we will join a pair of Polylines by moving the end vertex of one line onto the end 
vertex of a different Polyline.  Next we will break the single, joined Polyline into two parts then 
join them again by adding a line between them.  We will then copy and paste the Polyline before 
making one of them a different size using the Scale tool. 

Join a pair of Polyline objects by Moving a Vertex 
1. Open the Site file Exercise Polyline Join.rdd 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 
 

2. Select the Move Vertex tool  from the Drawing Toolbar 

3. Click on the end of one of the Polylines and move it to the end of the other Polyline, this 
joins the two Polylines together 

Break a Polyline into Two Parts 

1. Select the Break Polyline tool  from the Drawing Toolbar 

2. Click the Polyline somewhere near the middle 

3. Select the Move tool  from the Main Toolbar 

4. Move one Polyline away from the other 

Join the Polylines by Adding a Line 

1. Click the Add Polyline tool  on the Drawing Toolbar 

2. Click on the end of one Polyline 

3. Click on one end of the other Polyline to join the two together 

Copy and Paste the Polyline 

1. From the Main Toolbar, click the Copy button  then the Paste button  

2. Use the Move tool to move the new Polyline away from the original one 

Scale the Polyline in both X and Y axes 

1. From the Drawing Toolbar, select the Scale tool   

2. Click and hold the mouse on a Polyline then move the mouse right to increase the size 
of the Polyline or move the mouse to the left to make it smaller.  Note that the line is 
scaled in both axes. 

Scale the Polyline in only one axis 

1. Click the Tools button  on the Drawing Toolbar then select Ortho Mode 
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2. From the Drawing Toolbar, select the Scale tool   

3. Click and hold the mouse on a Polyline then move the mouse to the right to increase 
the size.  Note that the line is scaled in just one axis. 

4. Click the Tools button on the Drawing Toolbar then click Ortho Mode again to switch 
ortho mode off 

8.2 Exercise 2 – Joining Multiple Polylines 
As well as being able to join pairs of Polylines together we often want to join many Polylines and 
turn them into a single line. 
 
In this exercise we will join multiple Polylines to form a closed shape representing the coastline 
of the United Kingdom and Ireland. 

Join multiple Polylines 
1. Open the Site file Exercise UK.rdd 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 
 

2. Select all of the Polylines on the chart by clicking CTRL and ‘A’ on the keyboard or 
dragging a selection rectangle around all of the Polylines 

3. Click the Tools button  on the Drawing Toolbar then select Join Polylines Tool 

4. In the Join Polylines Tool dialog, set the Tolerance to 0.05m and click OK 

5. The chart will now show the coastline of the UK as a single, closed Polyline 
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8.3 Exercise 3 – Grouping Objects 
When you group drawing objects together you combine them so that you can work with them as 
if they were a single object. 
 
In this exercise we will compare the effects of moving and rotating individual and grouped 
objects. 

Group a set of drawing objects 
1. Open the Site file Exercise Group.rdd 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 

2. Select the Rotate tool  from the Main toolbar 

3. Click on one of the lines or grips of the blue rectangle and drag to rotate it.  Note how 
the single rectangle moves. 

4. Select all four objects by dragging a rectangle over them all with the mouse 

5. From the Drawing Toolbar, select Tools  then Group .  Note that the blue 
selection grips now surround all four objects. 

 

 
 
The selected objects will now behave like a single object so can be moved, rotated, scaled and 
flipped accordingly. 
 

6. Select the Move tool  from the Main toolbar 

7. Click on one of the lines or grips and drag the whole group to a new location 

8. Select the Rotate tool  from the Main toolbar 

9. Click on one of the lines or grips of the blue rectangle and drag to rotate it.  Note how 
the entire group of objects now moves 

Ungroup the objects 
1. Click on the grouped objects to select them  

2. From the Drawing Toolbar, select Tools  then Ungroup  

3. Repeat the rotate test on the blue rectangle and note how it moves on its own again 
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8.4 Exercise 4 – Display Stacking 
Objects automatically stack up in individual layers as you add them to the Chart. You can see 
the stacking order when filled objects overlap as the top object covers a portion of objects 
beneath it.  
 
You can move individual objects or groups of objects in a stack. For example, you can move 
objects up or down within a stack one step at a time or you can move them to the top or bottom 
of a stack in one move.  
 
There is a hierarchy of stacking in Site programs. Objects are drawn in the order defined by the 
Projects, the Layers within each Project and the object order within each Layer.  The objects on 
the bottom of the stack are drawn first; these are in the lowest layer in the lowest Project shown 
in the Layers display. Each object in subsequent layers is drawn next so filled objects in upper 
layers may hide objects lower down. 
 
In this exercise we will see the effects of display stacking on objects on the same Layer and 
objects on different Layers. 

To bring an object to the front in its own Layer 
1. Open the Site file Exercise Stacking.rdd (File | Open) 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 
  

2. Ensure that the Layer called Circles is visible and the Layers called Rectangles and 
Black Rectangle are hidden (Layer Display) 

3. Click on the edge of the green circle to select it 

4. From the Drawing Toolbar, select Tools  then Bring to Front  

This will move the green circle to the front or top so it partially hides the others underneath. 
 

5. From the Drawing Toolbar, select Tools  then Send to Back  

This will move the green circle to the back so it is partially hidden by the others underneath. 
 

6. From the Drawing Toolbar, select Tools  then Bring Forward  

This will move the green circle in front of the red circle but under the blue circle 

Change a Layer's stacking order 
1. In the Layers display, make the layer Rectangles visible.  Note that the rectangles are 

drawn under the circles 

2. In the Layers Display, click on the Layer called Rectangles then in the Layers Toolbar, 

select Bring to Front .   

Note that the Layer Rectangles is shown higher than the Layer called Circles in the Layers 
display and that the rectangles are now drawn on top of the circles on the chart 

Changing a Project’s stacking order  
1. In the Layers display, make the Layer called Black Rectangle visible, this is in the 

Project called Project 2 

2. Select the Project called Project 2 by clicking on it 

3. From the Layers Toolbar, click Bring to Front  

Note that the black rectangle is now drawn on top of the other rectangles and circles and the 
Project called Project 2 is shown above Project 1 in the Layers Display. 
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9 Adding Images to the Chart - Image Basemaps 

9.1 Exercise 1 – Scaling Image Basemaps 
Scaled images can be added to the chart to show such things as site sketches, sidescan sonar 
images, multibeam sonar images and aerial photographs.  For some Image Basemaps the 
scale or a fixed distance is known, a scanned site plan with a scale for example.  Once imported 
the image itself can easily be scaled so the distance is correct using the Scale Basemap tool. 
 
In this exercise we will add an Image Basemap then use the Scale Basemap tool to set its size 
correctly on the chart 

Add an Image Basemap: 
1. Create a new Site file (File | New Site) 

2. Show the Drawing Toolbar if not shown already.  From the View Menu select 
Toolbars then Drawing Toolbar 

3. Select the Layer ‘2010 General’ as the current Layer in the Layer Display.  Click on the 

Layer in the list then click the Set Current button  

4. Click anywhere on the chart to set it as the active display 

5. On the Drawing Toolbar click the Add Image Basemap button  

6. Click on the chart where you want to put the bottom left corner of the picture.  The 
properties pages for the Image Basemap will be shown. 

7. In the Property Pages, set a new Name or use the default 

8. Click the blank File property and an Open dialog will be displayed 

9. Navigate to the document file BVIStructure.tif, select it and click Open 

The test file can be found in C:\Site Files\Sample Files\ Site Images 
 

10. A preview of the image will now be shown in the Property Pages 

11. Click OK 

Set the Scale of the Image 

1. Pan and zoom the chart so the scale bar in 
the Image Basemap picture is visible 

2. Select the Image Basemap on the chart by 
clicking the border line around the outside or 
click the Image label text 

3. From the Tools menu, select Basemaps 
then Scale BaseMap 

4. Click on one end of the scale bar in the 
picture, hold the left mouse button down 
then drag the mouse to the other end of the 
scale bar and let go. 

5. The Scale Basemap Tool dialog is shown, 
type in a distance of 2.0 and click OK 

6. The selected image will then be scaled, use 
the Measure Tool to confirm the scaling is 
correct 
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9.2 Exercise 2 – Aligning Image Basemaps 
Where two points on the image should line up with two known points on the chart, the Align 
Basemap tool can be used to quickly and accurately put the image into position.  Two points are 
selected on the image and two corresponding points (ground control points) selected on the 
chart.   
 
In this exercise we will scale, rotate and position an Image Basemap using the Basemap Align 
Tool. 

Align a Basemap: 
1. Load the Site file Exercise Digitise Align.rdd 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 
 

2. Ensure that the Layers called 2008 Control and Basemap L are visible and the layers 
2008 Rocks, 2008 Timber and 2008 Outline are hidden 

3. On the chart, select the Image Basemap Image BM by clicking on it 

4. From the Tools menu, select Basemaps then Align Basemap.  The Align Basemap 
Tool will be displayed. 

5. Move the Align Basemap Tool off to one side of the chart so the chart can be seen 

6. Use the chart zoom and pan tools to help ensure that the point labelled CP1 on the 
Image Basemap is visible. 

7. In the tool, click the Source Point 1 button then click the Image Basemap in the middle 
of the reference point labelled CP1.   

8. In the tool, click the Destination Point 1 button and click the chart In the middle of 
Survey Point CP1.  A red ‘X’ will be shown at the destination point selected with label 
‘D1’. 

9. Repeat for Source Point 2 and Destination Point 2, lining up CP2 on the Image and 
the Survey Point CP2 on the chart. 

10. When the four points points are correctly placed, click the Align button on the Tool. 

The Image will be scaled, rotated and moved so the Source points on the image line up with the 
corresponding Destination points on the chart. 
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9.3 Exercise 3 – Digitising a Site Plan 
The imported, scaled, rotated and positioned Image Basemap can now be digitised to turn it into 
an electronic site plan. 
 
In this exercise we will digitise part of a scanned paper site plan, separating timbers, rocks and 
excavated extents onto separate Layers. 

Digitise the Image Basemap Timbers 
1. Load the Site file Exercise Digitise.rdd 

The file can be found in C:\Site Files\Sample Files.  For instructions on opening a Site file see 
section 6.1 Exercise – Using the Find Tool 
 

2. Ensure the Layer Basemap L is visible (found in the Project called Basemaps) 

3. Switch on the Layer called 2008 Timber (Layer display) 

4. Set this to be the current Layer (Layer Toolbar | Set Current) 

5. Add a Polyline (Drawing menu) and start tracing the outline of one of the timbers 
shown on the Image Basemap 

6. Join the ends of the Polyline to close it so it is shown filled with colour 

7. Repeat for some other timbers 

8. Set the 2008 Timber Layer Fill Style to None (Layer properties) 

9. Add detail lines to the timber drawings to represent areas of eroded timber 

10. Set the 2008 Timber Layer Fill Style to Solid (Layer properties) 

11. Note that the detail lines are drawn on top of the filled areas 

Digitise the Image Basemap Rocks 
12. Switch off the Layer 2008 Timbers (Layers Display) 

13. Switch on the Layer 2008 Rocks 

14. Set this to be the current Layer 

15. Add a Polyline and trace the outline of a rock, ensure the ends of the Polyline are joined 

16. Repeat for a number of other rocks 

Showing the Digitised Plan 
17. Switch off the Layer Basemap L (found in the Project called Basemaps) 

18. Switch on the Layers 2008 Timber, 2008 Rocks, 2008 Outline, 2008 Control 
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10 Survey Points and Measurements 

10.1 Exercise – Adding Survey Points and Measurements 
In this exercise we will create a new Site then add Survey Points and measurements to it.  We 
will simplify this exercise by using the default layer called 2010 Control found in any newly 
created Site file. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. On the New Site Wizard, set the name for the site to be Measurements then click 
Close 

4. In the Layers Display, select the Layer called 2010 Control and click the Set Current 

button  

Add four Survey Points: 
1. Click anywhere on the chart to select it 

2. Click the Add button on the Main toolbar and select Survey Point 

3. Click on the Chart in the top-left corner.  Properties for a Survey Point will be shown 
with the default name CP01. 

4. Set the Depth property to be 1.0 

5. Click OK and the point will be created 

6. Repeat for three other points CP2, CP3 and CP4 in the other corners of the Chart. 

 
Your Chart should now look like the picture. 
 
Notes: 

By setting the depth value a depth measurement has 
automatically been added to each point 
 
 
 
 
 
 
 

Add six Distance Measurements: 
1. Click the Add button on the Main toolbar and select Distance 

2. Left click and hold on the centre of Survey Point CP01, then drag the line to the centre 
of CP02 then release the mouse button. 

The properties for the Distance measurement are shown with a default Value property equal to 
the distance between the points on the Chart. 
 

3. Click OK and the Distance measurement will be shown on the Chart 

4. Repeat for Distances between CP01-CP03, CP01 – CP04, CP02 – CP03, CP02 – 
CP04 and CP03 – CP04. 

5. Save the file 
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Your Chart should now look like the picture. 
 
The sample Site file associated with this exercise is 
‘Exercise Adjust OK.rdd’. 
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11 3D Survey Processing 

11.1 Exercise 1 – Basic Adjustment 
In this exercise we will adjust the positions of the points added in the previous exercise and use 
the measurements to define the positions of the points.   
 
In the previous exercise we added a set of four Survey Points and added measurements 
between them.  All of the measurements added were perfect, they were correct for the positions 
of each point on the Chart.  If we use the measurements to adjust the positions of the points 
then the points should not move as the current point positions and the measurements agree.  Of 
we then move one of the points and re-adjust the network of points will return to its original 
shape. 
 
If this Site file from the previous exercise is not already open: 

Open the Site file: 
1. From the File menu select Open Site 

2. If prompted, save the old Site file if required 

3. Open the Site file from the previous exercise Measurements or use the file Exercise 
Adjust OK 

4. In the Layers Display, select the Layer 2008 Control then click the Set Current button 

on the Layers Toolbar  

5. Show the Adjust Toolbar.  From the View Menu select Toolbars then Adjust Toolbar 

 

Adjust the positions of the Survey Points: 

1. On the Adjust toolbar, click the Adjust button .  The message ‘Adjustment 
completed OK’ will be shown followed by the Statistics display.  Note the shape of the 
network of Survey Points. 

2. Using the Move tool  on the Main toolbar, move the position of any one of the 
Survey Points.  Note that the measurements go grey. 

3. Click the Adjust button again and the network of points should go back to the previous 
shape (but it may move and rotate slightly) and the measurements are again shown in 
green 

 
 
 
The sample Site file associated with this exercise is 
Exercise Adjust OK.rdd. 
 
The test file can be found in C:\Site Files\Sample 
Files 
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11.2 Exercise 2 – Finding Mistakes 
In this exercise we will use the Auto Rejection tool to find measurements that do not fit in a set 
of Survey Points and Measurements. 

Open the Site file: 
1. From the File menu select Open Site 

2. If prompted, save the old Site file if 
required 

3. Open the Site file Exercise Adjust 
Test.rdd 

The test file can be found in C:\Site 
Files\Sample Files, see section 6.1 Exercise – 
Using the Find Tool 
 
 
 
 

Adjust the positions of the Survey Points: 

1. On the Adjust toolbar, click the Adjust button .  The message ‘Adjustment 
completed OK’ will be shown.   

Note the colour of some of the distance measurements are blue or red indicating that one or 
more of the measurements is wrong.  The quality metric RMS of Residuals is also too high at 
0.101m, this is the Root-Mean-Square of the residuals and is similar to an average value. 
 

2. Click the Auto Rejection button on the Adjust toolbar .  This activates the auto 
rejection tool allowing the adjustment to identify and reject measurements. 

3. Click the Adjust button again and the measurements will all go green apart from three 
that are shown as magenta: CP06 – CP10, CP10 – CP11, CP02 – CP03 

 
 
The RMS Residuals quality figure is now an 
acceptable 15mm indicating that these 
measurements fit together well. 
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12  A Quick Assessment Survey using Radial Measurements 

12.1 Exercise – Radial Measurements 
In this exercise we will add and modify Radial measurements. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. In the New Site Wizard, set the name of the site to be Radial then click Close 

4. In the Layers Display, select the Layer 2010 Control then click the Set Current button 

on the Layers Toolbar  

Add a Survey Point: 
1. Click on the Chart to select it 

2. On the main menu click Add and select Survey Point, then click on the Chart in the 
centre.  Properties for a Survey Point will be shown with the default name CP01. 

3. Set the Depth property to 1.0 

4. Click OK and the point and a depth measurement will be created 

Add Radial Measurements: 
1. On the Main Toolbar click the Add button and select Radial then click on the centre of 

Survey Point CP01.  The property pages for the Radial measurement are shown. 

2. Set the distance Value property to 10m and Fwd Bearing property to 30.0 degrees 
then click OK 

3.  Add another radial measurement to CP01 with a Value of 7m and a Fwd Bearing of 
270 degrees 

4. Add another radial measurement to CP01 with a Value of 8m and a Fwd Bearing of 
160 degrees 

5. Add a radial measurement to CP02 this time with a Value of 10m and a Fwd Bearing 
of 280 degrees 

6. Double click the radial measurement from CP02 to CP05 and set the Fwd Bearing of 
260 degrees and a Value of 12m.  Click OK. 

 
Your Chart should now look like this picture > 
 
The sample Site file associated with this exercise is 
Exercise Radial.rdd. 
 
The test file can be found in C:\Site Files\Sample Files 
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13 Adding Detail with Offsets and Ties 

13.1 Exercise – Offsets and Ties 
In this exercise we will create a new Site, add Survey Points and a Baseline then attach offsets 
and ties measurements to it.  

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. In the New Site Wizard, set the name of the site to be Offset Ties then click Close 

4. In the Layers Display, select the Layer called 2010 Control and click the Set Current 

button  

Add two Survey Points: 
1. Click on the chart to select it 

2. On the Main menu click Add and select Survey Point.  Click on the chart in the lower-
left corner.  Properties for a Survey Point will be shown with the default name CP01. 

3. Set the Depth property to 1.0 

4. Click OK and the Survey Point and a Depth measurement will be created 

5. Add a second Survey Point in the top-right corner, at least 20m from point CP01. 

Add a Distance Measurement: 
1. On the main menu click Add and select Distance 

2. Left click and hold on the centre of Survey Point CP01, then drag the line to the centre 
of CP02 then release the mouse button.   

The properties for the Distance measurement are shown with a default Value property equal to 
the distance between the points on the chart. 
 

3. Click OK and the Distance measurement will be shown on the chart 

Add an Offset: 
1. On the main menu click Add and select Offset. Click anywhere on the new Baseline 

and the properties pages for the offset will be 
shown 

2. Set the Along value to be 7m and the Offset 
value to 7m 

3. Ensure the Is Right Side check box is set 
then click OK. 

 
This will add an offset to the right side of the 
baseline, as shown in the picture > 
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Add a Tie: 
1. On the main menu click Add and select Ties.   Click anywhere on the baseline and the 

properties pages for the ties will be shown. 

2. Set the Along 1 property to 12 m and set the Tie 1 property to 5 m 

3. Set the Along 2 property to 18m and the Tie 2 property to be 4m. 

4. Set the Along check property to be 15.5m and the Tie check property to 3.4m 

5. Unset the Is Right Side check box and click OK 

 
The optional check measurement gives a residual of 0.083m 
 
Your chart should now look like this picture > 
 
The sample Site file associated with this exercise is 
Exercise Offset Ties.rdd. 
 
The test file can be found in C:\Site Files\Sample 
Files 
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14 Artefacts 

14.1 Exercise 1 – Artefact Shapes 
In this exercise we will add a drawing shape to an Artefact by importing an existing drawing from 
a file.  Next we will associate two Survey Points with the Artefact and use the points to position 
the shape on the chart. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. In the New Site Wizard, set the name of the site to be Artefact Shape then click Close 

4. In the Layers Display, select the Layer called 2010 Artefacts and click the Set Current 

button  

Add an Artefact and its shape: 
1. On the Main Menu click Add and select Artefact 

2. Click on the centre of the chart where you want the Artefact to be placed and the 
properties pages for the Artefact will be shown 

3. Select the Position tab and click the Shape Editor button 

4. In the Shape Editor, click the Import button in the lower-left corner 

5. Select the file Cannon.dxf from the Sample Files folder. 

The test file can be found in the folder C:\Site Files\Sample Files 
 

6. On the Import Wizard File Page click Next 

7. On the Coordinates Page click Next 

8. On the Report Page click the Start button.  When complete click Finish 

9. Click the Move button on the Shape Editor toolbar and drag the red reference point 1 
to the middle of the base ring on the cannon 

10. Move Reference point 2 to the middle of the muzzle 

Your Shape Editor drawing should now 
look like this picture > 
 

11. Click the Close button on the 
Shape Editor 
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Add two Survey Points: 
1. On the Layers display set 2010 Control to be 

the current Layer 

2. Select the chart so the Main Toolbar buttons 
become enabled 

3. On the main menu click Add and select 
Survey Point.  Click on the chart in the 
lower-left corner.  Properties for a Survey 
Point will be shown with the default name 
CP01. 

4. Repeat for a second Survey Point CP02 in 
the top-right corner 

 
< Your chart should now look like this picture 

Associate the Survey Points with the Artefact: 
1. Double-click the Artefact on the chart to show its properties. 

2. Select the Positioning tab 

3. Click the Fixed by points radio button 

4. Select Point 1 to be CP01 and Point 2 to be CP02.  Click OK.  

To move the Artefact shape: 
• Using the Move tool on the Main toolbar, move either of the Survey Points and the 

Artefact shape will follow.    

 
The Shape will move so its primary reference point 
is on top of Survey Point CP01 and the secondary 
reference point lies as close as possible to the 
second Survey Point CP02. 
 
Your chart should now look like this picture > 
 
 
 
 
 
 
 
The sample Site file associated with this exercise is 
Exercise Artefact Shape.rdd. 
 
The test file can be found in C:\Site Files\Sample Files 
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14.2 Exercise 2 – Property Options and Wordlists 
The list of options available for any enumerated property in a property page is controlled by a 
wordlist.  The contents of the wordlist can be altered, changing the options offered for each 
property in the property page. 
 
In this exercise we will modify the wordlists used to provide options for one of the Artefact’s 
properties. 
 

To Modify the Property Options 
1. Double-click the Artefact Shape (or label) to show the Artefact’s properties page 

2. Set the Material property to ‘Composite’ and note that the option ‘Plastic’ is not 
available 

3. Click OK to close the Artefact property pages 

4. From the Tools Menu, select Word Lists 

5. Double click Arch Material from the table in the Wordlists dialog 

6. In the Arch Material table click the Add Word button, type in the new material ‘Plastic’  

7. Click on the material ‘Stone’ then click the button Delete Word 

8. Click OK to close the dialog 

9. In the Wordlists dialog click Close 

10. Double-click the Artefact Shape (or label) to again show the Artefact’s properties page 

11. Set the Material property to the newly available option ‘Plastic’.  Note that the option 
‘Stone’ is no longer available. 

12. Click OK to close the property pages 
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15 Using Drawing Frames 

15.1 Exercise – Adding a Drawing Frame 
In this exercise we will create a new Site, add Survey Points and a Baseline then attach a 
Drawing Frame to the Baseline. 

Create a new Site: 
1. From the File menu select New Site 

2. If prompted, save the old Site file if required 

3. On the New Site Wizard, set the name of the site to be Drawing Frame then click 
Close 

4. In the Layers Display, select the Layer called 2010 Control and click the Set Current 

button  

Add two Survey Points: 
1. Click on the chart to select it 

2. On the Main menu click Add and select Survey Point.  Click on the chart in the lower-
left corner.  Properties for a Survey Point will be shown with the default name CP01. 

3. Set the Depth property to be 1.0 

4. Click OK and the Survey Point and a Depth measurement will be created 

5. Add a second Survey Point in the top-right corner, at least 10m from point CP01. 

Add a Distance Measurement: 
1. On the main menu click Add and select Distance 

2. Left click and hold on the centre of Survey Point CP01, then drag the line to the centre 
of CP02 then release the mouse button. 

The properties for the new Distance measurement line on the chart are shown with a default 
distance Value property equal to the actual distance between the points on the chart. 
 

3. Click OK and the Distance measurement will be shown on the chart 

Add a Drawing Frame 
1. On the main menu click Add and select 

Drawing Frame.  Click anywhere on the 
chart 

2. Select the Position tab and click the Fixed 
by baseline button 

3. Select the baseline ObsCP01:02 and set the 
Along value to 6m.  Click OK to close the 
property page. 

 
Your chart should now look like this picture > 

To move the Drawing Frame: 
• Using the Move tool on the Main toolbar, move either of the Points and the Frame will 

follow.    
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To set the alignment of the Drawing Frame on the Baseline: 
1. Select the Position tab and click the Shape Editor button 

2. Click the Move button on the Shape Editor toolbar and drag the red reference point 1 
to coordinates 0.0, 0.1 

3. Move Reference point 2 to coordinates 1.0, 0.2 

To add a scanned drawing image: 
1. In the Shape Editor, click the Image button 

2. Select the image file Test Drawing.gif and click Open.   

This image will automatically scale to fit the drawing frame. 
 
Your Shape Editor drawing should now look like this picture > 
 

 
 

3. Click the Close button, at the prompt to show the image on the main chart click Yes.  

4. Click OK on the properties page 

 
< Your chart should now look like this picture 
 
The Frame now lies so that the both Reference 
points lie on the Baseline itself. 
 
If the image is not shown in the frame then 
double click the edge of the frame to show its 
properties and check that the Show Image 
property is checked. 
 
 
 
 
 
 

 
 
The sample Site file associated with this exercise is Exercise Drawing Frame.rdd. 
 
The test file can be found in the folder C:\Site Files\Sample Files 
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16 Features and Sectors  

16.1 Exercise – Associating Objects 
In this exercise we will create new Artefacts, Features and Sectors and associate them together 
using a realistic example: 
 

• A wreck site had an excavation trench 
defined by the bulkheads of the 
carpenter’s cabin 

• In the trench was found the lid of a 
box 

• Below the lid was found a box, the lid 
found earlier was the correct size to fit 
the box  

• Found inside the box were a chisel 
and a mallet 

• Also inside the box was the ‘ghost’ of 
a cloth bag, no cloth remained just a 
different colour sediment 

• Inside the ‘bag’ were found 10 
identical copper nails 

 
 
The illustration (right) is from the real example; in this exercise we will not create this drawing 
but something much simpler. 

Add Artefacts, Feature and Sector 
1. Ensure the Artefact Layer on which you want to add the new object is selected as the 

current Layer 

2. On the Main Menu click Add and select Artefact 

3. Click somewhere on the chart where the Artefact is to be placed.  The properties pages 
will be shown. 

4. Set the Name to be A0001 Lid then click OK 

5. Repeat for other new Artefacts A0002 Box, A0003 Chisel, A0004 Mallet and A0006 
Nails 

6. On the Main Menu, click Add and select Feature 

7. Click somewhere on the chart where the Feature is to be placed.  The properties page 
for the Feature will be shown. 

8. Set the Name to be A0005 Bag then click OK 

9. On the Main menu click Add and select Sector  

10. Click anywhere on the chart where the object is to be placed.  The properties page for 
the Sector will be shown. 

11. Set the Name to be Trench 1 then click OK. 

To associate Artefacts, Features and Sectors 
1. Open the properties for the Artefact A0006 Nails and open the Recording page 

2. Set the Association property to Contained By and Associated With to A0005 Bag 
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3. Open the properties for the Artefact A0005 Bag and open the Recording page 

4. Set the Association property to Contained By and Associated With to A0002 Box 

5. Repeat for A0003 Chisel and A0004 Mallet 

6. Open the properties for the Artefact A0001 Lid and open the Recording page 

7. Set the Association property to Part Of and Associated With to A0002 Box 

8. Open the properties for the Artefact A0002 Box and open the Recording page 

9. Set the Association property to Contained By and Associated With to Trench 1 

Show the Associations 

1. On the Main toolbar, click the Show Associations button  

2. In the Associations Display, click the + icon for the Site to show its associated objects 

3. Click the + icon for each associated object to open the tree and show the branches 

 

 
 
These relationships can be shown using the Associations display in the figure above.  This 
display shows the relationships between all archaeological objects in a hierarchy with the Site at 
the top followed by Sectors, Features and Artefacts.  Objects are then shown related to other 
objects with the type of relationship shown in square brackets [ ]. 
 
At the top of the ‘tree’ is the Site itself and below this is a Sector that represents Trench 1, 
contained by Trench 1 is the Box shown as A0002 Box. 
 
Below the Box is the Lid, A0001 Lid.  The Lid is shown below the Box as it is related by being 
‘Part of’ the Box.  Also below the Box are the Chisel and the Mallet represented by Artefacts 
A0003 Chisel and A0004 Mallet.   
 
Feature A0005 Bag represents the remains of the Bag, also ‘Contained by’ the Box.  Contained 
by the Bag Feature are the 10 Copper nails represented by Artefact A0006 Nails. 
 
 
The sample Site file associated with this exercise is Exercise Associations.rdd. 
 
The test file can be found in the folder C:\Site Files\Sample Files 
 
 
 

© 3H Consulting Ltd. 1998-2010 41



Site Recorder 4 Exercise Book 

17 Contacts and Dive Logs 

17.1 Exercise – Linking Contacts and Dive Logs 
In this exercise we will add some Contacts and link them to a Dive Log, then link the Dive Log to 
a Survey Point.  The Links property page for the Survey point will then be used to show which 
objects are linked to it. 

Create new Contacts: 

1. On the Main toolbar, click the Add New Display button  and select Contact.  This 
will show the List Display for Contacts 

Click the Add button on the Main toolbar and select Contact, set the Name to be Bill set 
the other properties if desired then click OK 

2. Repeat for two more new Contacts called Fred and Jim 

Create a Dive Log 

1. On the Main toolbar, click the Add New Display button  and select Dive Logs.  
This will show the List Display for Contacts 

Click the Add button on the Main toolbar and select Dive Log, the Dive Log properties will 
be shown with the default name for the Dive Log as DIV08-001 

2. Set Diver 1 to be Jim, Diver 2 to be Fred and the Supervisor to be Bill 

3. Click on the Time In property and set a date and time 

4. Click on the Time Out property and set a time after the Time In 

5. Click the Duration property and check that the correct time interval is shown 

6. Click OK to close the properties 

Add a Survey Point: 
 

1. On the Layers display, click on the Layer called 2010 Control in the Project called 2010 
Season 

2. Click the Set current button  or right click and select Set Current from the context 
menu.  Check that the 2010 Control label is now in bold font, showing that it is now the 
current Layer. 

3. Click anywhere on the chart display to select it 

4. Click the Add button  on the Main toolbar and select Survey Point 

5. Click a point on the chart where you want the Survey Point to be placed.  The property 
page for the Survey Point will now be shown 

6. Use the default name for the Survey Point but set the Dive Reference property to 
DIV08-0001 and click OK. 

7. Click the Select button  on the Main Toolbar or press the ESC key to stop adding 
Survey Points 
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Checking Links 
1. Double click the survey point on the chart to show its properties 

2. Click the Links tab 

3. Click the + in the links tree to show the Dive Log linked to this Survey Point 

4. Click the + in the links tree for the Dive Log to show the Contacts (Divers) linked to it 

5. Double click any item in the links tree to show that object’s properties. 

6. Close the properties page 

 

 
 
The Links page shows the objects that are linked to this object and allows you to navigate 
between them. 
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18 Images  

18.1 Exercise – Linking Images 
Pictures and video clips can be added to the Site as Image objects and these images can be 
linked to other objects.  In this exercise we will add a Target object, add an Image object and 
link the Image to the Target then show the image in an editing program and in the Image 
Preview display. 

Link a Single Image 
1. Create a new Site file (File | New Site) 

2. Ensure that a General Layer is selected as the current Layer (Layers Display | Set 
Current) 

3. Add a Target object to the Chart (Main Menu | Add | Target) 

4. Open the property pages for the Target (Double click) 

Click on the Image tab then click the Add button to show the Select Images dialog 

In the Select Images dialog click the Add New button.  A new Image object is created and 
its property pages are displayed. 

In the Image property page, set the name of the Image (or use the default) then click on the 
File property.  The Open dialog is shown. 

In the Open dialog, navigate to the image file Target.jpg  then click the Open button 

If the file was opened then it is shown in the preview pane on the Image properties page 
 
The test file can be found in the folder C:\Site Files\Sample Files\Site Images 
 

Set the other Image properties if desired then click OK 

In the Select Images dialog, click on the image to add (if it is not selected already) then 
click OK 

The Image is now shown in the list on the Images property page 

Open the Linked Image in an Editing Program 
1. In the Image tab in the objects Properties Pages, click the linked Image to edit then click 

Open Link 

2. Close the editing program and return to Site Recorder 

3. Close the Target properties page by clicking OK 

To show the Image Preview Display: 
1. On the Main Toolbar, click the Image Preview 

button  

2. Click on the Target and the image recently 
linked to it will be shown 

3. Click the maximise  button on the Image 
Preview display To show a larger image 

4. Click the restore button  to return it to the 
original size. 
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19 Sources 

19.1 Exercise – Linking Documents and Sources 
Documents, reports, letters, web pages and other sources can be recorded using Source 
objects.  As with Images, Source objects record information about the document but also 
provide a link to the document or web page if available on the computer or network.  The link 
provides a way to display or edit the document from within Site Recorder. 
 
In this exercise we will create a Source and link a PDF file to it, open the PDF file from the 
Source List Display then link the Source to a Target. 

Add a Source and link a document file to it: 
 

1. Create a new Site file (File | New Site) 

2. From the Main Menu, click the Add button  and select Source 

3. Set the Name property or use the default 

4. Click the right-hand column of the File property and an Open dialog is displayed 

5. Navigate to the document file CattewaterHiResNASNews.pdf, select it and click Open 

The test file can be found in the folder C:\Site Files\Sample Files 
 

6. Click OK and the Sources List Display will be shown 

7. Click on the new Source in the list to select it 

8. From the Tools menu, select Open Linked File and the linked document will now be 
shown.  Close the linked document. 

 

Link the Source to a Target 
 

1. Ensure that a General Layer is selected as the current Layer (Layers Display | Set 
Current) 

2. Add a Target object to the Chart (Main Menu | Add | Target) 

3. Open the property pages for the Target (Double click) 

4. Click on the Sources tab 

5. Click the Add button 

6. In the Select Sources dialog, click on the Source just added then click OK 

7. The linked Source should now be shown in the list in the Target’s Sources tab 

8. Click on the Source in the list to select it 

9. Click the Open Link button on the Sources tab to show the document file linked to the 
Source.  Close the linked document. 

10. Click the Properties button on the Sources tab to show the properties pages for the 
linked Source.  Close the Source properties pages by clicking OK or Cancel. 

11. Close the Target properties pages 
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20 Wrecks 

20.1 Exercise – Linking Site Files to Wrecks 
Wreck objects can be linked to other Site files so the linked file can be opened from within 
another Site file.  This allows the creation of ‘master’ site files that cover a wide area but contain 
only basic information about sites linked to many smaller Site files that each contains detailed 
information about a specific site. 
 
In this exercise we will create a Wreck object, link another Site file to it then open the linked Site 
file. 

Add a Wreck: 
1. Create a new Site file (File | New Site) 

2. In the Layers Display, Set a General Layer to be the current Layer (Layers Display). 

3. On the Main Toolbar, click the Add button then select Wreck from the menu 

4. Click on the Chart where the Wreck is to be added 

5. The property pages for the Wreck are shown, set the Name and fill in any other 
available information then click OK 

Link a Site File with the Wreck 
1. Double click the Wreck on the chart or list to show its Property Pages 

2. Click the Site File property and a file Open dialog is shown 

3. In the Open dialog, navigate to the Site file to link to and click Open 

4. Check that the Site File property now shows the correct path and file name for the 
selected Site file 

Open a Linked Site File 
1. Right click on the Wreck symbol on the chart and select Open Linked Site File from 

the menu.  The linked file will now open in a new Site Recorder program 

2. Close the new Site Recorder program 
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21 Named Views 

21.1 Exercise – Named Views 
If you find that you often want to show the same area of the site plan with the same set of 
Layers visible then you can use ‘Named Views’ to be able to set this up quickly.   

Add a named view: 
1. Load the Site file Exercise Digitise.rdd  

The file can be found in the folder C:\Site Files\Sample Files.  For instructions on opening a Site 
file see section 6.1 Exercise – Using the Find Tool 
 

2. Switch off all Layers apart from Basemap L (found in the Project called Basemaps) 

3. Set the chart to show the whole of the site plan using the chart zoom and pan tools 

4. In the small Named Views toolbar, click the Named Views button 

5. In the Named Views Dialog, click New View 

6. Type in the name for this view as All View  then click OK. 

7. In the Named Views Dialog click Close 

8. Zoom and pan the chart so it just shows the area around CP01 on the image 

9. Add another Named view (4 to 7 above) but call this CP1 View 

Select an existing named view: 
1. In the Named Views toolbar, select the Named View called All View using the list 

control 

2. Note how the chart scale and centre changes so the 
first view is shown 

3. Select the Named View called CP1 View 

4. Note how the chart scale and centre changes so the 
second view is shown 
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22 Importing, Converting and Merging Information 

22.1 Exercise 1 - Importing 
In this exercise we are going to import a sample drawing from a Drawing eXchange (DXF) file. 

Import the drawing: 
1. Create a new Site file (File | New Site) 

2. From the File menu, select Import Wizard 

3. In the Open Import File dialog, select the file Import Test.DXF and click Open 

The test file can be found in the folder C:\Site Files\Sample Files. 
 

4. In the File Page click Next 

5. In the Layer Page, set the Project to be 2010 Season and click Next 

6. In the Coordinates Page just click Next 

7. In the Select Page, click the empty box to the left of Site: ‘My Site’.  Red tick marks will 
appear in all of the empty boxes.  Click Next. 

8. In the Report Page click Start.  Click Finish when the file has been imported. 

9. On the Chart Toolbar, click the Zoom All button to show the imported drawing 
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22.2 Exercise 2 - Converting 
In this exercise we will open a Site file containing Points and convert them to Artefacts. 

To convert the points: 
1. From the File menu select Open Site 

2. Select the file Exercise Convert and click Open 

The test file can be found in the folder C:\Site Files \Sample Files.    For instructions on opening 
a Site file see section 6.1 Exercise – Using the Find Tool 

 

3. Select all of the Points on the Chart by dragging a select rectangle around them with the 
mouse 

4. From the Tools menu select Convert Tool 

5. Select Artefact as the object type to convert to  

6. Select 2008 Artefacts as the Layer to move the new objects to 

7. Ensure that Delete the original objects is checked 

8. Click OK and all the Points will be converted to Artefact objects 

9. Show the properties for one of the new Artefacts to check that it has been converted 
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22.3 Exercise 3 - Merging 
Objects from existing Site files can easily be added by using the Merge Wizard.  The Wizard 
allows you to select a Site file to merge from then select particular Layers within that file to 
include in your existing Site. 
 
In this exercise we will copy a gun Artefact from one Site file to another. 

Merge objects from other files: 
1. Create a new Site file (File | New Site) 

2. Select Merge Wizard from the File Menu on the Main toolbar 

3. Select the Site file SAMPLE Reader Test.rdd and click Open 

The file can be found in the folder C:\Site Files\Sample Files.  For instructions on opening a Site 
file see section 6.1 Exercise – Using the Find Tool 
 

4. On the Select page, select the Layer 2010 Artefacts to import objects from by clicking 
the small grey box to the left of the Layer name.  When selected a red tick will be shown 
in the grey box.   

5. Click Next 

6. On the Report page, click the Start button and the objects will be imported. 

7. Click the Finish button on the Merge Wizard 

8. Click Zoom All on the Chart Toolbar to show the imported Artefact object 

9. Show the Artefact properties by double clicking the drawing outline or the name label 

10. Note that the imported object includes the objects drawing and properties. 
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23 Publishing 

23.1 Exercise 1 – Getting Ready to Publish 
In this exercise we will add a copyright notice to the chart and choose to leave out a Layer from 
the packaged file. 

Add a Copyright Notice to the Chart: 
1. Open the Site file Exercise Publish.rdd 

The file can be found in the folder C:\Site Files\Sample Files.  For instructions on opening a Site 
file see section 6.1 Exercise – Using the Find Tool 
 

2. From the Tools menu select Chart Properties 

3. Click the Show Copyright Text option 

4. Set the Copyright Text to ‘Copyright 3H Consulting Ltd’ 

5. Click Close and the copyright text will be shown on the chart. 

Omit a Layer from a Packaged File 
1. On the Layer Display, double click the Layer 2008 Outline 

2. Uncheck the Allow Package property then click OK 

23.2 Exercise 2 - Publishing 
In this exercise we will package up the Site file so it can be shared or published.  This will take 
copies of any linked image files and put them in a folder called \Site Images under the folder 
used for the packaged Site file.  Links to these image files in the packaged Site file will be 
updated to use the copied files instead. 

Package the Site file for sharing: 
1. Ensure that Exercise 1 above has been completed 

2. Select Package for CD/Web from the 
File Menu on the Main toolbar.  The 
Package Wizard File Page is shown. 

3. Select the packaging option Sharing the 
Site file. 

4. Use the default file name and folders 
and click Next 

 
 

5. In the Security Page, click Next. 

6. In the Options Page, click Next. 

7. On the Report Page, click on the Start 
button to create the packaged file. 

8. Open the packaged file 

9. Open the properties for the Image Basemap Image BM and check that the File property 
has been changed to the relative filepath \Site Images\BVIStructure.tif 

10. In the Layer Dialog, check that the Layer 2008 Outline is missing, as selected above 

11. On the chart, check that the copyright notice is visible, as selected above 
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24 Exporting Information 

24.1 Exercise - Exporting 
In this exercise we will export information about Survey Points to a comma separated (CSV) file 

Export information to a file: 
1. Open the Site file Exercise Adjust OK.rdd 

The file can be found in the folder C:\Site Files\Sample Files.  For instructions on opening a Site 
file see section 6.1 Exercise – Using the Find Tool 
 

2. Select Export Wizard from the File menu 

3. Select the File Type to be exported as Comma Separated Variable (CSV) and click 
Next 

4. Select Export objects by type, select Survey Point and press Next 

5. On the Co-ordinates Page click Next 

6. In the Export File dialog, set the file name to be Survey Points Export.csv and click 
Next 

7. In the File Page, click Next 

8. In the Report Page, click the Start button to export the file then click the Finish button 

9. In a spreadsheet program such as MS Excel, open the file Survey Points Export.csv 
and check that the four survey points and their properties have been exported correctly 
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